Home » Questions » Computers [ Ask a new question ]

The water does not heat up

The water does not heat up

The Thermal Cutoff Fuse has an impedance of 0.4 KOhm. I believe this is OK, but please correct me if I am wrong. When plugged in the blue light does come on the kettle, but the water does not heat up. Do you have any ideas on where else the problem might be? Thanks in advance.

Asked by: Guest | Views: 87
Total answers/comments: 2
Guest [Entry]

"Could be any of several things. Let’s go straight to the horses mouth and see if they have a solution:

https://www.justanswer.com/sip/oster?r=p..."
Guest [Entry]

"Hi @Charles Kolarik

Try de-scaling the kettle.

This is from the user manual

“Ensure kettle is off and unplugged. Mineral deposits in tap water may cause scale deposits to form inside the electric kettle after frequent use.

To remove this scale build-up, fill the kettle with a solution of 3 cups of white vinegar and 3 cups water. Let sit overnight.

2. Empty the vinegar solution from the electric kettle. Remove any stain remaining inside by rubbing with a damp cloth.

3. Fill the electric kettle with clean water. Place kettle on power base and bring to a boil, then discard water. Repeat and the electric kettle will be ready to use.

4. The electric kettle will not operate again until the on/off switch is pressed downward.

5. Always remove kettle from power base and disconnect power base from electrical outlet before cleaning. Do not immerse kettle or power base in water or other liquid.

The outside of the electric kettle can be wiped with a soft damp cloth.

NOTE: Never use any chemical, steel wool, or abrasive cleaners to clean any part of the kettle, including the power base"