Home » Questions » Goods and Services [ Ask a new question ]

New battery is not charging and condition says replace now?

New battery is not charging and condition says replace now?

I just replaced the battery on my Macbook Air 13" mid 2011, one I ordered from iFixIt and the computer recognizes it, but it says cycle count: 0 and condition: replace now.

Asked by: Guest | Views: 70
Total answers/comments: 5
bert [Entry]

"fluxcomputerrepair

@flux


Rep: 49
Flux Computer Repair




5"
bert [Entry]

"@neven

Sounds good. I assume you have also reset the PRAM during your troubleshooting? Sorry it didn't work for you. Yes...it's quite frustrating. The other option is using a different supplier for your battery completely or going for a used battery from iFixit to see if that gets you by. Good luck and if you get it sorted out please drop a note on this thread."
bert [Entry]

Unfortunately, even though this is a four year old thread now, and I hate posting in it, but, it seems to still be happening, and I cannot get the system to run from the battery no matter how much I reset the SMC from the OS or even when powered off. I’m guessing the bad iFixit battery issue has reared its ugly head at the end of 2019. Are there any other ways to attempt to correct the battery condition, or do I just need to try and get a new replacement battery? Its a late 2011 macbook pro. And yes, I even reset the PRAM attempting to fix this. I did get it to not recognize the battery entirely once, but then it just went back to not running from the battery like before after another SMC reset.
bert [Entry]

I replaced my MacBook Air battery after the battery wouldn’t charge. It worked fine for a few days and now the new battery won’t charge. I am not sure what to do. 2013 model
bert [Entry]

"Can you please help me I installed the battery into my macbook pro 2014 a few months ago and everything was fine and now it's only operating at 50% capacity and i'm getting less than 4 hours life on it. I have tried a battery calibration, a SMC and a PRAM reset and i still get a ""service recommended"" warning on the battery

Can you help me please?"