Home » Questions » Information [ Ask a new question ]

Smok X-Priv will not heat up coil

Smok X-Priv will not heat up coil
My xpriv voltage stays at 0.500 volts and the coil wont heat up the tank works on other mods. Can someone please help me

answers:

"I had a simmilar problem on my SMOK x-priv. If you look in the bottom right corner there is a timer, that should track how long the current puff is.

The problem was that it was just continuesly resetting the timer and firing constantly for a split second each time. at such a low voltage where it wouldn't heat the coil enough.

If your timer is also stuck at 0.1s all while holding the trigger, take it back to the store."
Check all the internal settings, watts, etc. Take the coil out and reinstall, prime, reset internal settings to new coil, etc. Coil might not be installed right enough or maybe it burnt if not primed properly first time. Charger plugged in should tell you how full batteries are…fully charge for several hours. Ohms should be about .4 and volts should be 4-5 if it's the original pieces in the kit. 60 watt setting should be fine depending on juice. Coil should be fine well above this. Picked up mine last week and love it.
Had same issues even though my batter indicator says 50% no fire put 100% batteries in and bam it hit got 4 batteries swapping 2-3 times a day waiting for new 3000 mah i never turned if off for first few weeks now i do to conserve battery .
Hi guys, I know this is a old post but for anyone looking in the future I was having the same problem and fixed mine after finding this YouTube comment. You will need a T6 screwdriver/ bit
Well, i was having the same problem,

Asked by: Guest | Views: 120
Total answers/comments: 0