Home » Questions » Information [ Ask a new question ]

TCL Roku tv turns on with logo for a fraction of sec, then black out

TCL Roku tv turns on with logo for a fraction of sec, then black out

Hello, I have Model 55S405 TCL Roku TV. When I turn it on it flashes roku tcl logo for a fraction of sec and then screen blacks out. I unplugged tv for 15 mins and overnight , I tried to reset it by pushing reset button and I tried reset from roku remote using “home button 4 times, up arrow 1 time, rewind 2 times and forward 2 times” but nothing worked.

ANSWERS:

"I had exactly the same problem. I found a temp fix for it at the moment, but it is not an ideal solution.

Anyways, I believe the problem is caused by 1 or more faulty LEDs in the back. I believe this somehow alters the voltage and it somehow triggers a safety mechanism to turn the LEDS off(since they are working at start). I figured that lowering brightness might lower the voltage on the LEDs and that it would not trigger the safety mechanism. I put it on the darkest settings(I turned on the T.V in a pitch black room to be able to see the settings). I turned it back on and it was working. However, it sometimes still triggers what I assume to be a safety mechanism of some sort every once in a while. I just turn the T.V off and on and it should work. If it does not work, then just unplug and redo it.

I know this is not a good fix, but at least it allowed me to watch a Star trek episode on it."

My model 50S425 that is a bit over 1 year old, started doing the same thing.  Was working fine one minute then shut off a show to put my son to bed, after that the tv would turn on, show the red TCL logo screen then turn back off after about 15 seconds.  Then after 10 seconds or so it would turn back on by itself, spend 15 seconds stuck on the red logo screen and turn back off.  It would stay stuck on this loop until I pulled the plug.  I tried everything I read online.  Unplugging made no difference, 1 hr, overnight, still the same red logo loop.  Every trick to fix it I read online didn't work.

Main board replacement solved the flashing splash screen > turning off issue on my TCL 65”. As another poster mentioned, it's a very simple fix and relatively inexpensive. I personally didn't know which board would solve my issue so I bought all 5 for ~$70 at ShopJimmy. Started with the power board, which wasn't the problem, then main board, and wha-la!…it was working. Replaced all the other boards once I determined it to be a main board issue, since I was in there and had replacements on hand. Tossed the original main board and held on to the others, just in case.

Asked by: Guest | Views: 60
Total answers/comments: 0