Home » Questions » Goods and Services [ Ask a new question ]

My phone won't turn on but the blue light is flashing

My phone won't turn on but the blue light is flashing

Help! My phone won't turn on. The blue light is flashing intermittently but the screen is black. It won't take calls. Tried to reset but no joy. It's only 3 weeks old. Any ideas?

Asked by: Guest | Views: 283
Total answers/comments: 6
bert [Entry]

Hold volume down and the power button until the phone reboots.
bert [Entry]

Hold the volume down and power button together for a few seconds. Dont listen to anyone about damaged LCD, just needs a reboot
bert [Entry]

"It is more than likely that the LCD behind is damaged in someway.

Check for signs of cracks on the LCD (not the glass on top), also there could be a possibility the plug has come out, it seems to be very common in the S5 models, but not entirely sure if the S5 mini is the same or not.

If you don't see any cracks, or any physical damage to the phone i would suggest you try to take it back under warranty."
bert [Entry]

Hold the volume down and power button together for a few seconds is not working.
bert [Entry]

Pull out your battery . Look in the top right corner / small circle . There is a test strip there . If it has turned pink or red it has liquid damage . That is the answer I got when I called my trac fone tech person . Had it only 5 days . Could get a refund if I sent it back but its working for what I need it for .
bert [Entry]

I had and still have the same problem. Everything I know about this is that when you press the home or power button to wake it, it doesn't turn on the screen. I could hear the sound when taking screenshots, also the sound when adjusting the volume rocker. When you hold the power button, you get the power options menu, by doing that, taking a screenshot and looking at the screenshot later, I could see the menu. That's how I discovered the actual issue. You may think of how I could see the screenshot later: My phone (yours could be different) worked fine when in the shadow, inside the car but once I get outside, on the sun, the issue appears. I don't know how this condition affects the screen. I'd rather stick to the restart solution.