Home » Questions » Information [ Ask a new question ]

unsupported version in my new 2015 Accord

unsupported version in my new 2015 Accord
My Ipod Model A1059 wont work in my new car, it says unsupported version. Can I update it or trash it.

ANSWERS:

Asked by: Guest | Views: 115
Total answers/comments: 0